summaryrefslogtreecommitdiffstats
path: root/source/xap/xsane/xsane.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/xap/xsane/xsane.SlackBuild')
-rwxr-xr-xsource/xap/xsane/xsane.SlackBuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/source/xap/xsane/xsane.SlackBuild b/source/xap/xsane/xsane.SlackBuild
index b8130201e..22264ca1c 100755
--- a/source/xap/xsane/xsane.SlackBuild
+++ b/source/xap/xsane/xsane.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2008, 2009, 2011, 2015, 2018 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2011, 2015, 2018, 2020 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=xsane
VERSION=0.999
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -51,12 +51,16 @@ PKG=$TMP/package-xsane
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
rm -rf $PKG
@@ -114,6 +118,9 @@ cp -a \
rm -f $PKG/usr/doc/xsane-$VERSION/xsane.spec*
( cd $PKG/usr/doc/xsane-$VERSION ; ln -s /usr/share/sane/xsane/doc html )
+mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/gimp/2.0/plug-ins
+( cd $PKG/usr/lib${LIBDIRSUFFIX}/gimp/2.0/plug-ins ; ln -s /usr/bin/xsane xsane )
+
# Compress and link manpages, if any:
if [ -d $PKG/usr/man ]; then
( cd $PKG/usr/man