summaryrefslogtreecommitdiffstats
path: root/source/x/marisa/marisa.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/x/marisa/marisa.SlackBuild')
-rwxr-xr-xsource/x/marisa/marisa.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/source/x/marisa/marisa.SlackBuild b/source/x/marisa/marisa.SlackBuild
index f21f027d4..682e0f834 100755
--- a/source/x/marisa/marisa.SlackBuild
+++ b/source/x/marisa/marisa.SlackBuild
@@ -107,8 +107,8 @@ make install DESTDIR=$PKG || exit 1
cd bindings/perl
perl Makefile.PL \
- INC="-I$TMP/marisa-$VERSION/lib" \
- LIBS="-L$TMP/marisa-$VERSION/lib/.libs" \
+ INC="-I$PKG/usr/include" \
+ LIBS="-L$PKG/usr/lib${LIBDIRSUFFIX}" \
PREFIX=/usr \
INSTALLDIRS=vendor
@@ -119,16 +119,16 @@ cd -
cd bindings/python
python setup.py build_ext \
- --include-dirs="$TMP/marisa-$VERSION/lib" \
- --library-dirs="$TMP/marisa-$VERSION/lib/.libs" || exit 1
+ --include-dirs="$PKG/usr/include" \
+ --library-dirs="$PKG/usr/lib${LIBDIRSUFFIX}" || exit 1
python setup.py install \
--root=$PKG || exit 1
cd -
cd bindings/ruby
ruby extconf.rb \
- --with-opt-include="$TMP/marisa-$VERSION/lib" \
- --with-opt-lib="$TMP/marisa-$VERSION/lib/.libs" \
+ --with-opt-include="$PKG/usr/include" \
+ --with-opt-lib="$PKG/usr/lib${LIBDIRSUFFIX}" \
--vendor
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1