summaryrefslogtreecommitdiffstats
path: root/source/x/libpinyin/libpinyin.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/x/libpinyin/libpinyin.SlackBuild')
-rwxr-xr-xsource/x/libpinyin/libpinyin.SlackBuild13
1 files changed, 2 insertions, 11 deletions
diff --git a/source/x/libpinyin/libpinyin.SlackBuild b/source/x/libpinyin/libpinyin.SlackBuild
index daaf9f278..67ec0aae8 100755
--- a/source/x/libpinyin/libpinyin.SlackBuild
+++ b/source/x/libpinyin/libpinyin.SlackBuild
@@ -1,9 +1,7 @@
#!/bin/bash
-# Slackware build script for libpinyin
-
# Copyright 2017 Heinz Wiesinger, Amsterdam, The Netherlands
-# Copyright 2017, 2020 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2017, 2020, 2021 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,8 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=libpinyin
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d- | rev)}
-MODEL_VERSION=${MODEL_VERSION:-17}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
@@ -89,12 +86,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-# Don't download model data
-cp $CWD/model${MODEL_VERSION}.text.tar.lz ./data/
-
-sed -i "/wget.*model${MODEL_VERSION}\.text\.tar\.gz/ d" data/Makefile.am
-sed -i "s|.tar.gz|.tar.lz|g" data/Makefile.am
-
if [ ! -r configure ]; then
if [ -x ./autogen.sh ]; then
NOCONFIGURE=1 ./autogen.sh