summaryrefslogtreecommitdiffstats
path: root/source/x/freeglut/freeglut.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/x/freeglut/freeglut.SlackBuild')
-rwxr-xr-xsource/x/freeglut/freeglut.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/source/x/freeglut/freeglut.SlackBuild b/source/x/freeglut/freeglut.SlackBuild
index 88c0b4b2a..7a4cadc85 100755
--- a/source/x/freeglut/freeglut.SlackBuild
+++ b/source/x/freeglut/freeglut.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=freeglut
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
@@ -77,19 +77,16 @@ cd $PKGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Fix header installation:
-sed -i -e '76s/SRCS/HEADERS/' CMakeLists.txt
+ -exec chmod 644 {} \+
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION/html
cp -a \
AUTHORS COPYING* INSTALL NEWS README TODO \
$PKG/usr/doc/$PKGNAM-$VERSION
cp -a doc/*.{html,png} $PKG/usr/doc/$PKGNAM-$VERSION/html
-find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+find $PKG/usr/doc -type f -exec chmod 0644 {} \+
mkdir -p build
cd build