summaryrefslogtreecommitdiffstats
path: root/source/x/freeglut/freeglut.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/x/freeglut/freeglut.SlackBuild')
-rwxr-xr-xsource/x/freeglut/freeglut.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/source/x/freeglut/freeglut.SlackBuild b/source/x/freeglut/freeglut.SlackBuild
index f1e10c978..88c0b4b2a 100755
--- a/source/x/freeglut/freeglut.SlackBuild
+++ b/source/x/freeglut/freeglut.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=freeglut
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
@@ -81,6 +81,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Fix header installation:
+sed -i -e '76s/SRCS/HEADERS/' CMakeLists.txt
+
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION/html
cp -a \
AUTHORS COPYING* INSTALL NEWS README TODO \