summaryrefslogtreecommitdiffstats
path: root/source/n/yptools/yptools.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/n/yptools/yptools.SlackBuild')
-rwxr-xr-xsource/n/yptools/yptools.SlackBuild21
1 files changed, 12 insertions, 9 deletions
diff --git a/source/n/yptools/yptools.SlackBuild b/source/n/yptools/yptools.SlackBuild
index 7baeeb619..3b876935a 100755
--- a/source/n/yptools/yptools.SlackBuild
+++ b/source/n/yptools/yptools.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2008, 2009, 2010, 2011, 2012, 2013 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2010, 2011, 2012, 2013, 2014, 2016 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,25 +23,25 @@
# Package version number:
VERSION=2.14
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-7}
YPTOOLS=$VERSION
-YPBINDMT=1.37.1
+YPBINDMT=1.38
#YPMAKE=0.11
-YPSERV=2.31
+YPSERV=2.32.1
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
+ i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "s390" ]; then
SLKCFLAGS="-O2"
@@ -196,12 +196,14 @@ cd ypserv-$YPSERV || exit 1
# --enable-tcp-wrapper
./configure \
--libdir=/usr/lib${LIBDIRSUFFIX} \
+ --libexecdir=/usr/lib${LIBDIRSUFFIX}/yp \
--enable-fqdn \
--enable-yppasswd \
$ARCH-slackware-linux
make clean
./configure \
--libdir=/usr/lib${LIBDIRSUFFIX} \
+ --libexecdir=/usr/lib${LIBDIRSUFFIX}/yp \
--enable-fqdn \
--enable-yppasswd \
$ARCH-slackware-linux
@@ -229,7 +231,7 @@ for FILE in ypserv rpc.yppasswdd rpc.ypxfrd yppush ; do
cat ${FILE}.8 | gzip -9c > $PKG/usr/man/man8/${FILE}.8.gz )
done
cat rpc.yppasswdd/yppasswdd.8 | gzip -9c > $PKG/usr/man/man8/yppasswdd.8.gz
-cat scripts/ypMakefile > $PKG/var/yp/Makefile.new
+cat scripts/ypMakefile | sed "s,/usr/lib/yp,/usr/lib$LIBDIRSUFFIX/yp,g" > $PKG/var/yp/Makefile.new
cat etc/securenets > $PKG/var/yp/securenets.new
echo "# This file is part of the YP server package -- see 'man netgroup'" \
> $PKG/etc/netgroup.new
@@ -281,7 +283,8 @@ config etc/rc.d/rc.yp.new
config var/yp/nicknames.new
config var/yp/Makefile.new
config var/yp/securenets.new
-rm -f etc/nsswitch.conf.new etc/nsswitch.conf-nis.new etc/netgroup.new etc/yp.conf.new var/yp/nicknames.new var/yp/Makefile.new var/yp/securenets.new
+# No, don't delete these. They might have a few changes that need to be merged.
+#rm -f etc/nsswitch.conf-nis.new etc/netgroup.new etc/yp.conf.new var/yp/nicknames.new var/yp/Makefile.new var/yp/securenets.new
EOF
cat $CWD/slack-desc > $PKG/install/slack-desc