summaryrefslogtreecommitdiffstats
path: root/source/n/pssh/pssh.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/n/pssh/pssh.SlackBuild')
-rwxr-xr-xsource/n/pssh/pssh.SlackBuild36
1 files changed, 24 insertions, 12 deletions
diff --git a/source/n/pssh/pssh.SlackBuild b/source/n/pssh/pssh.SlackBuild
index a251d4b96..c8a9dad1d 100755
--- a/source/n/pssh/pssh.SlackBuild
+++ b/source/n/pssh/pssh.SlackBuild
@@ -1,6 +1,6 @@
-#!/bin/sh
+#!/bin/bash
-# Copyright 2008, 2009, 2010, 2011 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2010, 2011, 2018 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,19 +22,30 @@
# required: package "python" version 2.2 or higher installed
-VERSION=2.3.1
-BUILD=1
+cd $(dirname $0) ; CWD=$(pwd)
+
+PKGNAM=pssh
+VERSION=${VERSION:-$(echo pssh*.tar.gz | cut -d - -f 2 | rev | cut -f 3- -d . | rev)}
+BUILD=${BUILD:-3}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) export ARCH=i486 ;;
+ i?86) export ARCH=i586 ;;
arm*) export ARCH=arm ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) export ARCH=$( uname -m ) ;;
esac
fi
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
+ exit 0
+fi
+
PREFIX=/usr
if [ "$ARCH" = "x86_64" ]; then
@@ -43,7 +54,6 @@ else
LIBDIRSUFFIX=""
fi
-CWD=$(pwd)
TMP=${TMP:-/tmp}
PKG=$TMP/package-pssh
rm -rf $PKG
@@ -60,13 +70,15 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-for library in psshlib/* ; do
- # This will force removepkg to remove all runtime-compiled *.pyc files
- touch ${library}c
-done
+# fix python3 issues
+zcat $CWD/pssh-2.3.1-py3-import.patch.gz | patch -p1 --verbose || exit 1
+zcat $CWD/pssh-2.3.1-py3-min-int-none.patch.gz | patch -p1 --verbose || exit 1
+zcat $CWD/pssh-2.3.1-py3-non-blocking.patch.gz | patch -p1 --verbose || exit 1
+zcat $CWD/pssh-2.3.1-py3-str-bytes-encode.patch.gz | patch -p1 --verbose || exit 1
+zcat $CWD/pssh-read-stdin-as-bytes-in-Python-3.patch.gz | patch -p1 --verbose || exit 1
-# Install:
-python setup.py build install --root=$PKG
+# Install
+python3 setup.py build install --root=$PKG
# Compress manual pages:
find $PKG/usr/man -type f -exec gzip -9 {} \;