summaryrefslogtreecommitdiffstats
path: root/source/n/pssh/pssh.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/n/pssh/pssh.SlackBuild')
-rwxr-xr-xsource/n/pssh/pssh.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/source/n/pssh/pssh.SlackBuild b/source/n/pssh/pssh.SlackBuild
index add643775..f323f7793 100755
--- a/source/n/pssh/pssh.SlackBuild
+++ b/source/n/pssh/pssh.SlackBuild
@@ -66,9 +66,9 @@ cd pssh-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
# fix python3 issues
zcat $CWD/pssh-2.3.1-py3-import.patch.gz | patch -p1 --verbose || exit 1
@@ -81,7 +81,7 @@ zcat $CWD/pssh-read-stdin-as-bytes-in-Python-3.patch.gz | patch -p1 --verbose ||
python3 setup.py build install --root=$PKG
# Compress manual pages:
-find $PKG/usr/man -type f -exec gzip -9 {} \;
+find $PKG/usr/man -type f -exec gzip -9 {} \+
for i in $( find $PKG/usr/man -type l ) ; do
ln -s $( readlink $i ).gz $i.gz
rm $i