summaryrefslogtreecommitdiffstats
path: root/source/n/obexftp/obexftp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/n/obexftp/obexftp.SlackBuild')
-rwxr-xr-xsource/n/obexftp/obexftp.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/source/n/obexftp/obexftp.SlackBuild b/source/n/obexftp/obexftp.SlackBuild
index 939cb95bf..825f8431a 100755
--- a/source/n/obexftp/obexftp.SlackBuild
+++ b/source/n/obexftp/obexftp.SlackBuild
@@ -76,9 +76,9 @@ cd ${PKGNAM}-${VERSION}-Source || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
# Thanks to Fedora for these
zcat $CWD/patches/obexftp-0.24-fix-absurd-install-path.patch.gz | patch -p1 || exit 1
@@ -163,7 +163,7 @@ cp -a \
AUTHORS COPYING* INSTALL NEWS README* THANKS TODO contrib \
$PKG/usr/doc/${PKGNAM}-$VERSION
rm -f $PKG/usr/doc/${PKGNAM}-$VERSION/contrib/Makefile*
-find $PKG/usr/doc/${PKGNAM}-$VERSION -type f -exec chmod 0644 {} \;
+find $PKG/usr/doc/${PKGNAM}-$VERSION -type f -exec chmod 0644 {} \+
# If there's a ChangeLog, installing at least part of the recent history
# is useful, but don't let it get totally out of control:
@@ -174,7 +174,7 @@ if [ -r ChangeLog ]; then
fi
# Remove perllocal files:
-find $PKG -name perllocal.pod -exec rm "{}" \;
+find $PKG -name perllocal.pod -exec rm "{}" \+
# This removes our DESTDIR from the packlist filenames, to keep perl's
# internal inventories consistent and correct.