summaryrefslogtreecommitdiffstats
path: root/source/n/getmail/getmail.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/n/getmail/getmail.SlackBuild')
-rwxr-xr-xsource/n/getmail/getmail.SlackBuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/source/n/getmail/getmail.SlackBuild b/source/n/getmail/getmail.SlackBuild
index b42a760d4..1830c241d 100755
--- a/source/n/getmail/getmail.SlackBuild
+++ b/source/n/getmail/getmail.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2008, 2009, 2010, 2017, 2018 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2010, 2017, 2018, 2020 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=getmail
-VERSION=${VERSION:-$(echo getmail-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+VERSION=${VERSION:-$(echo getmail6-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
@@ -50,16 +50,13 @@ rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
-rm -rf getmail-$VERSION
-tar xvf $CWD/getmail-$VERSION.tar.?z || exit 1
-chown -R root:root getmail-$VERSION
-cd getmail-$VERSION || exit 1
+rm -rf getmail6-$VERSION
+tar xvf $CWD/getmail6-$VERSION.tar.?z || exit 1
+chown -R root:root getmail6-$VERSION
+cd getmail6-$VERSION || exit 1
-# Fix shebang in a couple files
-sed -i -e "s|#![ ]*/usr/bin/env python2.3|#!/usr/bin/env python2|" $(find . -name '*.py')
-
-python setup.py build || exit 1
-python setup.py install --root=$PKG || exit 1
+python3 setup.py build || exit 1
+python3 setup.py install --root=$PKG || exit 1
( cd $PKG/usr/share
mv man ..
@@ -76,4 +73,3 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
# Build the package:
cd $PKG
/sbin/makepkg -l y -c n $TMP/getmail-$VERSION-$ARCH-$BUILD.txz
-