summaryrefslogtreecommitdiffstats
path: root/source/l/v4l-utils/v4l-utils.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/v4l-utils/v4l-utils.SlackBuild')
-rwxr-xr-xsource/l/v4l-utils/v4l-utils.SlackBuild33
1 files changed, 22 insertions, 11 deletions
diff --git a/source/l/v4l-utils/v4l-utils.SlackBuild b/source/l/v4l-utils/v4l-utils.SlackBuild
index da7839940..9c0b2ec4f 100755
--- a/source/l/v4l-utils/v4l-utils.SlackBuild
+++ b/source/l/v4l-utils/v4l-utils.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Copyright 2009 Eric Hameleers, Eindhoven, NL
-# Copyright 2009, 2010, 2011 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2009, 2010, 2011, 2013 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PKGNAM=v4l-utils
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -70,17 +70,24 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Fix manpage path:
-sed -i "s,share/man/,man/,g" utils/keytable/Makefile
+# Configure:
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --disable-static \
+ --build=$ARCH-slackware-linux
# Build and install:
-export CFLAGS="$SLKCFLAGS"
-export CPPFLAGS="$SLKCFLAGS"
-export LDFLAGS="$SLKLDFLAGS"
-make ${NUMJOBS} PREFIX=/usr LIBDIR=/usr/lib${LIBDIRSUFFIX} || \
- make PREFIX=/usr LIBDIR=/usr/lib${LIBDIRSUFFIX} MANDIR=/usr/man || \
- exit 1
-make install PREFIX=/usr LIBDIR=/usr/lib${LIBDIRSUFFIX} MANDIR=/usr/man DESTDIR=$PKG || exit 1
+make $NUMJOBS || make || exit 1
+make install DESTDIR=$PKG || exit 1
+
+# These shouldn't be used:
+rm -f $PKG/usr/lib${LIBDIRSUFFIX}/*.la
# System udev files should go under /lib:
if [ -r $PKG/etc/udev/rules.d/70-infrared.rules ]; then
@@ -92,6 +99,10 @@ if [ -r $PKG/etc/udev/rules.d/70-infrared.rules ]; then
sed -i "s,/etc/udev/rules.d,/lib/udev/rules.d,g" $PKG/lib/udev/rules.d/70-infrared.rules
fi
+# I'd rather see these remain in /etc where they have been:
+mv $PKG/lib/udev/rc_keymaps/* $PKG/etc/rc_keymaps
+rmdir $PKG/lib/udev/rc_keymaps
+
# Strip binaries:
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null