summaryrefslogtreecommitdiffstats
path: root/source/l/v4l-utils/v4l-utils.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/v4l-utils/v4l-utils.SlackBuild')
-rwxr-xr-xsource/l/v4l-utils/v4l-utils.SlackBuild44
1 files changed, 40 insertions, 4 deletions
diff --git a/source/l/v4l-utils/v4l-utils.SlackBuild b/source/l/v4l-utils/v4l-utils.SlackBuild
index 5b96939c1..c0ffa36b7 100755
--- a/source/l/v4l-utils/v4l-utils.SlackBuild
+++ b/source/l/v4l-utils/v4l-utils.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Copyright 2009 Eric Hameleers, Eindhoven, NL
-# Copyright 2009, 2010 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2009, 2010, 2011 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
PKGNAM=v4l-utils
-VERSION=0.8.0
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+BUILD=${BUILD:-2}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -70,6 +70,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Fix manpage path:
+sed -i "s,share/man/,man/,g" utils/keytable/Makefile
+
# Build and install:
export CFLAGS="$SLKCFLAGS"
export CPPFLAGS="$SLKCFLAGS"
@@ -79,16 +82,49 @@ make ${NUMJOBS} PREFIX=/usr LIBDIR=/usr/lib${LIBDIRSUFFIX} || \
exit 1
make install PREFIX=/usr LIBDIR=/usr/lib${LIBDIRSUFFIX} DESTDIR=$PKG || exit 1
+# System udev files should go under /lib:
+if [ -r $PKG/etc/udev/rules.d/70-infrared.rules ]; then
+ mkdir -p $PKG/lib/udev/rules.d
+ mv $PKG/etc/udev/rules.d/70-infrared.rules $PKG/lib/udev/rules.d
+ rmdir $PKG/etc/udev/rules.d 2> /dev/null
+ rmdir $PKG/etc/udev 2> /dev/null
+ rmdir $PKG/etc 2> /dev/null
+ sed -i "s,/etc/udev/rules.d,/lib/udev/rules.d,g" $PKG/lib/udev/rules.d/70-infrared.rules
+fi
+
# Strip binaries:
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+# Compress and if needed symlink the man pages:
+if [ -d $PKG/usr/man ]; then
+ ( cd $PKG/usr/man
+ for manpagedir in $(find . -type d -name "man*") ; do
+ ( cd $manpagedir
+ for eachpage in $( find . -type l -maxdepth 1) ; do
+ ln -s $( readlink $eachpage ).gz $eachpage.gz
+ rm $eachpage
+ done
+ gzip -9 *.?
+ )
+ done
+ )
+fi
+
# Add a documentation directory:
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a \
- COPYING* ChangeLog README* TODO \
+ COPYING* README* TODO \
$PKG/usr/doc/$PKGNAM-$VERSION
+# If there's a ChangeLog, installing at least part of the recent history
+# is useful, but don't let it get totally out of control:
+if [ -r ChangeLog ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
+ cat ChangeLog | head -n 1000 > $DOCSDIR/ChangeLog
+ touch -r ChangeLog $DOCSDIR/ChangeLog
+fi
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc