summaryrefslogtreecommitdiffstats
path: root/source/l/urwid/urwid.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/urwid/urwid.SlackBuild')
-rwxr-xr-xsource/l/urwid/urwid.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/source/l/urwid/urwid.SlackBuild b/source/l/urwid/urwid.SlackBuild
index 85f5bbe88..f5f3bd4c8 100755
--- a/source/l/urwid/urwid.SlackBuild
+++ b/source/l/urwid/urwid.SlackBuild
@@ -60,9 +60,9 @@ cd $PKGNAM-$VERSION || exit 1
chown -R root.root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
python setup.py install --root=$PKG || exit 1
python3 setup.py install --root=$PKG || exit 1
@@ -74,7 +74,7 @@ mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
# Include the code examples. They're pretty small, so they can't hurt, I guess.
# NOTE: They don't even exist in 1.0.3, so even smaller, I guess. ;-)
cp -a CHANGELOG COPYING* examples $PKG/usr/doc/$PKGNAM-$VERSION
-find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 644 {} \;
+find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 644 {} \+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc