summaryrefslogtreecommitdiffstats
path: root/source/l/system-config-printer/system-config-printer.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/system-config-printer/system-config-printer.SlackBuild')
-rwxr-xr-xsource/l/system-config-printer/system-config-printer.SlackBuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/source/l/system-config-printer/system-config-printer.SlackBuild b/source/l/system-config-printer/system-config-printer.SlackBuild
index 98370a806..948b5f5f3 100755
--- a/source/l/system-config-printer/system-config-printer.SlackBuild
+++ b/source/l/system-config-printer/system-config-printer.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 2010, 2011, 2012 Eric Hameleers, Eindhoven, NL
-# Copyright 2010, 2011, 2012, 2013, 2018, 2020, 2021 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2010, 2011, 2012, 2013, 2018, 2020, 2021, 2022, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=system-config-printer
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-2}
NUMJOBS=${NUMJOBS:-" -j$(expr $(nproc) + 1) "}
@@ -89,6 +89,11 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
+# Fix missing required file:
+if [ ! -r ChangeLog ]; then
+ touch ChangeLog
+fi
+
# Configure:
if [ ! -r configure ]; then
if [ -x ./autogen.sh ]; then
@@ -108,7 +113,9 @@ PYTHON=/usr/bin/python3 \
--docdir=/usr/doc/$PKGNAM-$VERSION \
--localstatedir=/var/lib \
--sysconfdir=/etc \
+ --with-udevdir=/lib/udev \
--with-udev-rules \
+ --with-systemdsystemunitdir=no \
--program-prefix= \
--program-suffix= \
--build=$TARGET || exit 1
@@ -128,14 +135,10 @@ python3 setup.py install --root=$PKG || exit 1
python3 -m compileall "${PKG}/usr/share/system-config-printer"
python3 -O -m compileall "${PKG}/usr/share/system-config-printer"
-# Move the udev files to the usual Slackware location:
-mkdir -p $PKG/lib
-mv $PKG/etc/udev $PKG/lib/
-
# Move the dbus configs to the system location:
mkdir -p $PKG/usr/share/dbus-1/system.d/
mv $PKG/etc/dbus-1/system.d/* $PKG/usr/share/dbus-1/system.d/
-rmdir --parents $PKG/etc/dbus-1/system.d/
+rm -rf $PKG/etc/dbus-1
if [ ! -L /lib${LIBDIRSUFFIX}/libpam.so.? ]; then
# Looks like PAM is not installed. Instead, your user must be in group 'lp'.