summaryrefslogtreecommitdiffstats
path: root/source/l/speech-dispatcher/speech-dispatcher.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/speech-dispatcher/speech-dispatcher.SlackBuild')
-rwxr-xr-xsource/l/speech-dispatcher/speech-dispatcher.SlackBuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/source/l/speech-dispatcher/speech-dispatcher.SlackBuild b/source/l/speech-dispatcher/speech-dispatcher.SlackBuild
index 9ef0055c3..f3321531b 100755
--- a/source/l/speech-dispatcher/speech-dispatcher.SlackBuild
+++ b/source/l/speech-dispatcher/speech-dispatcher.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=speech-dispatcher
SRCNAM=speech-dispatcher
VERSION=${VERSION:-$(echo $SRCNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-1}
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
@@ -36,7 +36,7 @@ PKG=$TMP/package-$PKGNAM
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i586 ;;
- arm*) readelf /usr/bin/file -A | egrep -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
+ arm*) readelf /usr/bin/file -A | grep -E -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$(uname -m) ;;
esac
@@ -90,9 +90,6 @@ find -L . \
sed -i "s/cicero //g" configure.ac
sed -i "s/sd_cicero//g" src/modules/Makefile.am
-# Fix build with glib-2.68.0:
-zcat $CWD/a2faab416e42cbdf3d73f98578a89eb7a235e25a.patch.gz | patch -p1 --verbose || exit 1
-
autoreconf -vif || exit 1
CFLAGS="$SLKCFLAGS" \