summaryrefslogtreecommitdiffstats
path: root/source/l/redland/redland.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/redland/redland.SlackBuild')
-rwxr-xr-xsource/l/redland/redland.SlackBuild54
1 files changed, 42 insertions, 12 deletions
diff --git a/source/l/redland/redland.SlackBuild b/source/l/redland/redland.SlackBuild
index 893d80efe..85ee69242 100755
--- a/source/l/redland/redland.SlackBuild
+++ b/source/l/redland/redland.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Copyright 2007 Heinz Wiesinger <hmwiesinger@gmx.at>
-# Copyright 2008, 2009 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2010 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,17 +22,28 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Modified by Robby Workman <rworkman@slackware.com>
+# Modified by Eric Hameleers <alien@slackware.com>
# No added terms and no copyright claims
-VERSION=1.0.8
-ARCH=${ARCH:-x86_64}
+PKGNAM=redland
+VERSION=${VERSION:-1.0.10}
BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:--j6}
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) export ARCH=i486 ;;
+ arm*) export ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) export ARCH=$( uname -m ) ;;
+ esac
+fi
+
CWD=$(pwd)
TMP=${TMP:-/tmp}
-PKG=$TMP/package-redland
+PKG=$TMP/package-$PKGNAM
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
@@ -43,14 +54,18 @@ elif [ "$ARCH" = "s390" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
-rm -rf redland-$VERSION
-tar xvf $CWD/redland-$VERSION.tar.bz2 || exit 1
-cd redland-$VERSION || exit 1
+rm -rf $PKGNAM-$VERSION
+tar xvf $CWD/$PKGNAM-$VERSION.tar.?z* || exit 1
+cd $PKGNAM-$VERSION || exit 1
+
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -58,6 +73,16 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+if [ "$VERSION" = "1.0.9" ]; then
+ echo "Fixing a bug in redland-1.0.9 that breaks nepomuk..."
+ for i in MYSQL POSTGRESQL SQLITE TSTORE; do
+ sed -i "s/LIBADD = @${i}_LIBS@/LIBADD = @${i}_LIBS@ librdf.la/" \
+ src/Makefile.in
+ done
+elif [ "$VERSION" = "1.0.10" ]; then
+ sed -i "s/virtuoso_la_LIBADD = @ODBC_LIBS@/virtuoso_la_LIBADD = @ODBC_LIBS@ librdf.la/" src/Makefile.in
+fi
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -67,9 +92,14 @@ CXXFLAGS="$SLKCFLAGS" \
--localstatedir=/var \
--mandir=/usr/man \
--disable-static \
+ --with-included-ltdl=no \
+ --with-bdb-lib=/usr/lib${LIBDIRSUFFIX} \
--with-threads \
--build=$ARCH-slackware-linux
+# Prevent error "No rule to make target `-lltdl', needed by `librdf.la'"
+sed -i -e 's# -lltdl$# #' -e '/^LIBS =/s# = # = -lltdl #' src/Makefile
+
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
@@ -81,18 +111,18 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" \
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)
-mkdir -p $PKG/usr/doc/redland-$VERSION
+mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a \
AUTHORS COPYING* INSTALL INSTALL.html LICENSE* NEWS* NOTICE \
README* RELEASE.html TODO* \
- $PKG/usr/doc/redland-$VERSION
-( cd $PKG/usr/doc/redland-$VERSION
- ln -s /usr/share/gtk-doc/html/redland html
+ $PKG/usr/doc/$PKGNAM-$VERSION
+( cd $PKG/usr/doc/$PKGNAM-$VERSION
+ ln -s /usr/share/gtk-doc/html/$PKGNAM html
)
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $TMP/redland-$VERSION-$ARCH-$BUILD.txz
+/sbin/makepkg -l y -c n $TMP/$PKGNAM-$VERSION-$ARCH-$BUILD.txz