summaryrefslogtreecommitdiffstats
path: root/source/l/redland/redland.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/redland/redland.SlackBuild')
-rwxr-xr-xsource/l/redland/redland.SlackBuild17
1 files changed, 2 insertions, 15 deletions
diff --git a/source/l/redland/redland.SlackBuild b/source/l/redland/redland.SlackBuild
index 16d90675c..2e8dc2ce9 100755
--- a/source/l/redland/redland.SlackBuild
+++ b/source/l/redland/redland.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2007 Heinz Wiesinger <hmwiesinger@gmx.at>
+# Copyright 2007, 2013 Heinz Wiesinger, Amsterdam, NL
# Copyright 2008, 2009, 2010, 2011, 2012 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
@@ -28,7 +28,7 @@
PKGNAM=redland
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-4}
+BUILD=${BUILD:-1}
NUMJOBS=${NUMJOBS:--j7}
@@ -84,16 +84,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-if [ "$VERSION" = "1.0.9" ]; then
- echo "Fixing a bug in redland-1.0.9 that breaks nepomuk..."
- for i in MYSQL POSTGRESQL SQLITE TSTORE; do
- sed -i "s/LIBADD = @${i}_LIBS@/LIBADD = @${i}_LIBS@ librdf.la/" \
- src/Makefile.in
- done
-elif [ "$VERSION" = "1.0.10" ]; then
- sed -i "s/virtuoso_la_LIBADD = @ODBC_LIBS@/virtuoso_la_LIBADD = @ODBC_LIBS@ librdf.la/" src/Makefile.in
-fi
-
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
@@ -109,9 +99,6 @@ CXXFLAGS="$SLKCFLAGS" \
--with-threads \
--build=$TARGET
-# Prevent error "No rule to make target `-lltdl', needed by `librdf.la'"
-sed -i -e 's# -lltdl$# #' -e '/^LIBS =/s# = # = -lltdl #' src/Makefile
-
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1