summaryrefslogtreecommitdiffstats
path: root/source/l/python-six/python-six.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/python-six/python-six.SlackBuild')
-rwxr-xr-xsource/l/python-six/python-six.SlackBuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/source/l/python-six/python-six.SlackBuild b/source/l/python-six/python-six.SlackBuild
index fae7e8b70..368928400 100755
--- a/source/l/python-six/python-six.SlackBuild
+++ b/source/l/python-six/python-six.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=python-six
VERSION=${VERSION:-$(echo six-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -78,14 +78,13 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-python setup.py install --root=$PKG || exit 1
python3 setup.py install --root=$PKG || exit 1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
-cp -a LICENSE PKG-INFO README $PKG/usr/doc/$PKGNAM-$VERSION
+cp -a LICENSE* PKG-INFO README* $PKG/usr/doc/$PKGNAM-$VERSION
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc