summaryrefslogtreecommitdiffstats
path: root/source/l/python-random2/python-random2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/python-random2/python-random2.SlackBuild')
-rwxr-xr-xsource/l/python-random2/python-random2.SlackBuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/source/l/python-random2/python-random2.SlackBuild b/source/l/python-random2/python-random2.SlackBuild
index e8173117c..a291d834e 100755
--- a/source/l/python-random2/python-random2.SlackBuild
+++ b/source/l/python-random2/python-random2.SlackBuild
@@ -36,7 +36,7 @@ fi
PKGNAM=python-random2
SRCNAM=random2
VERSION=${VERSION:-$(echo ${SRCNAM}-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-2}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -72,7 +72,9 @@ find -L . \
rm -f setuptools/*.exe
-python3 setup.py install --root=$PKG || exit 1
+unshare -n python3 -m build --wheel --no-isolation || exit 1
+
+python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a CHANGES* PKG-INFO README* \