summaryrefslogtreecommitdiffstats
path: root/source/l/python-notify2/python-notify2.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/python-notify2/python-notify2.SlackBuild')
-rwxr-xr-xsource/l/python-notify2/python-notify2.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/source/l/python-notify2/python-notify2.SlackBuild b/source/l/python-notify2/python-notify2.SlackBuild
index 56010587d..c25a13eb5 100755
--- a/source/l/python-notify2/python-notify2.SlackBuild
+++ b/source/l/python-notify2/python-notify2.SlackBuild
@@ -57,9 +57,9 @@ cd $SRCNAM-$VERSION || exit 1
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python setup.py install --root=$PKG || exit 1
python3 setup.py install --root=$PKG || exit 1
@@ -67,7 +67,7 @@ python3 setup.py install --root=$PKG || exit 1
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a *.rst LICENSE PKG-INFO \
$PKG/usr/doc/$PKGNAM-$VERSION
-find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 0644 {} \;
+find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 0644 {} \+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc