summaryrefslogtreecommitdiffstats
path: root/source/l/python-future/python-future.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/python-future/python-future.SlackBuild')
-rwxr-xr-xsource/l/python-future/python-future.SlackBuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/source/l/python-future/python-future.SlackBuild b/source/l/python-future/python-future.SlackBuild
index 3f262a69d..c3bd2537b 100755
--- a/source/l/python-future/python-future.SlackBuild
+++ b/source/l/python-future/python-future.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2020 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2020, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=python-future
SRCNAM=future
VERSION=${VERSION:-$(echo ${SRCNAM}-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-5}
-
+BUILD=${BUILD:-2}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -61,10 +60,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# Clear the build folder:
-rm -rf build
+unshare -n python3 -m build --wheel --no-isolation || exit 1
-python3 setup.py install --root=$PKG || exit 1
+python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a *.rst LICENSE* NOTICE PKG-INFO \