summaryrefslogtreecommitdiffstats
path: root/source/l/python-docutils/python-docutils.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/python-docutils/python-docutils.SlackBuild')
-rwxr-xr-xsource/l/python-docutils/python-docutils.SlackBuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/source/l/python-docutils/python-docutils.SlackBuild b/source/l/python-docutils/python-docutils.SlackBuild
index 3dd51412b..6bbf75897 100755
--- a/source/l/python-docutils/python-docutils.SlackBuild
+++ b/source/l/python-docutils/python-docutils.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2017, 2018, 2019, 2020 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2017, 2018, 2019, 2020, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# Copyright 2017 Heinz Wiesinger, Amsterdam, NL
# All rights reserved.
#
@@ -25,7 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=python-docutils
VERSION=${VERSION:-$(echo docutils-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
SRCNAM=docutils
@@ -61,11 +61,16 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py build --build-lib=build/python3 install --root=$PKG || exit 1
+unshare -n python3 -m build --wheel --no-isolation || exit 1
+python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
+
+# Gotta be careful with that *
cd $PKG/usr/bin
for i in *.py; do
- ln -s "$i" "$PKG/usr/bin/$(basename $i .py)"
+ if [ -r "$i" ]; then
+ ln -s "$i" "$PKG/usr/bin/$(basename $i .py)"
+ fi
done
cd -