summaryrefslogtreecommitdiffstats
path: root/source/l/python-distro/python-distro.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/python-distro/python-distro.SlackBuild')
-rwxr-xr-xsource/l/python-distro/python-distro.SlackBuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/source/l/python-distro/python-distro.SlackBuild b/source/l/python-distro/python-distro.SlackBuild
index dd06fd17f..45f7780dc 100755
--- a/source/l/python-distro/python-distro.SlackBuild
+++ b/source/l/python-distro/python-distro.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2017, 2020 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2017, 2020, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# Copyright 2017, 2018 Heinz Wiesinger, Amsterdam, NL
# All rights reserved.
#
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=python-distro
SRCNAM=distro
VERSION=${VERSION:-$(echo $SRCNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-4}
+BUILD=${BUILD:-2}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -60,9 +60,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-# python2 dropped dropped as obsolete.
-#python setup.py install --root=$PKG || exit 1
-python3 setup.py install --root=$PKG || exit 1
+unshare -n python3 -m build --wheel --no-isolation || exit 1
+
+python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a *.rst CHANGELOG* CONTRIBUTING* LICENSE* README* \