summaryrefslogtreecommitdiffstats
path: root/source/l/python-chardet/python-chardet.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/python-chardet/python-chardet.SlackBuild')
-rwxr-xr-xsource/l/python-chardet/python-chardet.SlackBuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/source/l/python-chardet/python-chardet.SlackBuild b/source/l/python-chardet/python-chardet.SlackBuild
index 509e9979d..50380c201 100755
--- a/source/l/python-chardet/python-chardet.SlackBuild
+++ b/source/l/python-chardet/python-chardet.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2017 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2017, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# Copyright 2017, 2018 Heinz Wiesinger, Amsterdam, NL
# All rights reserved.
#
@@ -25,7 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=python-chardet
VERSION=${VERSION:-$(echo chardet-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-2}
SRCNAM=chardet
@@ -61,7 +61,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG || exit 1
+unshare -n python3 -m build --wheel --no-isolation || exit 1
+
+python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a *.rst LICENSE* PKG-INFO \