summaryrefslogtreecommitdiffstats
path: root/source/l/python-PyYAML/python-PyYAML.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/python-PyYAML/python-PyYAML.SlackBuild')
-rwxr-xr-xsource/l/python-PyYAML/python-PyYAML.SlackBuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/source/l/python-PyYAML/python-PyYAML.SlackBuild b/source/l/python-PyYAML/python-PyYAML.SlackBuild
index 2e51000bc..d24aa269a 100755
--- a/source/l/python-PyYAML/python-PyYAML.SlackBuild
+++ b/source/l/python-PyYAML/python-PyYAML.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2021 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2021, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -60,7 +60,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG || exit 1
+unshare -n python3 -m build --wheel --no-isolation || exit 1
+
+python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a *.rst LICENSE* NOTICE PKG-INFO \