summaryrefslogtreecommitdiffstats
path: root/source/l/pyparsing/pyparsing.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/pyparsing/pyparsing.SlackBuild')
-rwxr-xr-xsource/l/pyparsing/pyparsing.SlackBuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/source/l/pyparsing/pyparsing.SlackBuild b/source/l/pyparsing/pyparsing.SlackBuild
index 2fc38dfff..f10e71dcb 100755
--- a/source/l/pyparsing/pyparsing.SlackBuild
+++ b/source/l/pyparsing/pyparsing.SlackBuild
@@ -29,7 +29,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=pyparsing
VERSION=${VERSION:-$(echo pyparsing-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-4}
+BUILD=${BUILD:-2}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -63,7 +63,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG || exit 1
+unshare -n python3 -m build --wheel --no-isolation || exit 1
+
+python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true