summaryrefslogtreecommitdiffstats
path: root/source/l/pyparsing/pyparsing.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/pyparsing/pyparsing.SlackBuild')
-rwxr-xr-xsource/l/pyparsing/pyparsing.SlackBuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/source/l/pyparsing/pyparsing.SlackBuild b/source/l/pyparsing/pyparsing.SlackBuild
index a03d7baea..c55c53488 100755
--- a/source/l/pyparsing/pyparsing.SlackBuild
+++ b/source/l/pyparsing/pyparsing.SlackBuild
@@ -63,16 +63,23 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python setup.py install --root=$PKG || exit 1
python3 setup.py install --root=$PKG || exit 1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
-cp -a CHANGES LICENSE* PKG-INFO README* HowToUsePyparsing.html \
+cp -a CHANGES LICENSE* PKG-INFO README* docs/HowToUsePyparsing.* \
$PKG/usr/doc/$PKGNAM-$VERSION
+# If there's a CHANGES file, installing at least part of the recent history
+# is useful, but don't let it get totally out of control:
+if [ -r CHANGES ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
+ cat CHANGES | head -n 1000 > $DOCSDIR/CHANGES
+ touch -r CHANGES $DOCSDIR/CHANGES
+fi
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc