summaryrefslogtreecommitdiffstats
path: root/source/l/pycurl/pycurl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/pycurl/pycurl.SlackBuild')
-rwxr-xr-xsource/l/pycurl/pycurl.SlackBuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/source/l/pycurl/pycurl.SlackBuild b/source/l/pycurl/pycurl.SlackBuild
index a0f0b2b5b..997533003 100755
--- a/source/l/pycurl/pycurl.SlackBuild
+++ b/source/l/pycurl/pycurl.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2012, 2018, 2019 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2012, 2018, 2019, 2024 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -62,7 +62,9 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-python3 setup.py --with-openssl install --root=$PKG || exit 1
+unshare -n python3 -m build --wheel --no-isolation || exit 1
+
+python3 -m installer --destdir "$PKG" dist/*.whl || exit 1
find $PKG | xargs file | grep -e "shared object" -e "executable" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null