summaryrefslogtreecommitdiffstats
path: root/source/l/pycurl/pycurl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/pycurl/pycurl.SlackBuild')
-rwxr-xr-xsource/l/pycurl/pycurl.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/source/l/pycurl/pycurl.SlackBuild b/source/l/pycurl/pycurl.SlackBuild
index 67d79c8db..ff8b88e6d 100755
--- a/source/l/pycurl/pycurl.SlackBuild
+++ b/source/l/pycurl/pycurl.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2012, 2018 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2012, 2018, 2019 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=pycurl
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -62,8 +62,8 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-python setup.py --with-ssl install --root=$PKG || exit 1
-python3 setup.py --with-ssl install --root=$PKG || exit 1
+python setup.py --with-openssl install --root=$PKG || exit 1
+python3 setup.py --with-openssl install --root=$PKG || exit 1
find $PKG | xargs file | grep -e "shared object" -e "executable" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null