summaryrefslogtreecommitdiffstats
path: root/source/l/netpbm/netpbm.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/netpbm/netpbm.SlackBuild')
-rwxr-xr-xsource/l/netpbm/netpbm.SlackBuild122
1 files changed, 122 insertions, 0 deletions
diff --git a/source/l/netpbm/netpbm.SlackBuild b/source/l/netpbm/netpbm.SlackBuild
new file mode 100755
index 000000000..0b6685c12
--- /dev/null
+++ b/source/l/netpbm/netpbm.SlackBuild
@@ -0,0 +1,122 @@
+#!/bin/sh
+
+# Copyright 2006, 2007, 2008, 2009 Patrick J. Volkerding, Sebeka, MN, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+
+PKGNAM=netpbm
+VERSION=${VERSION:-10.35.22}
+ARCH=${ARCH:-x86_64}
+BUILD=${BUILD:-2}
+
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "s390" ]; then
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp}
+PKG=$TMP/package-${PKGNAM}
+rm -rf $PKG
+mkdir -p $TMP # Do not create $PKG or 'make package' fails
+
+cd $TMP
+rm -rf ${PKGNAM}-${VERSION}
+tar xvf $CWD/${PKGNAM}-$VERSION.tar.bz2 || exit 1
+cd ${PKGNAM}-$VERSION
+
+# Make sure ownerships and permissions are sane:
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Configure:
+if [ "$ARCH" = "x86_64" ]; then
+ zcat $CWD/Makefile.config.gz \
+ | sed -e '/^CFLAGS/s/^CFLAGS = .*/& -fPIC/' > Makefile.config
+else
+ zcat $CWD/Makefile.config.gz > Makefile.config
+fi
+
+# Build and install (does not like parallel build):
+make || exit 1
+make package pkgdir=$PKG || exit 1
+
+# Strip binaries:
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
+
+# Put things in proper directories:
+( cd $PKG
+ rm README
+ mkdir -p usr
+ mv * usr
+ cd usr
+ mkdir -p doc/netpbm-$VERSION
+ mv VERSION bin/doc.url doc/netpbm-$VERSION
+ ( cd lib ; ln -sf libnetpbm.so.10 libnetpbm.so )
+ mv lib lib${LIBDIRSUFFIX}
+ rm -rf config_template link misc pkginfo man/man1/manweb.1 man/web
+)
+
+# Compress and link manpages, if any:
+if [ -d $PKG/usr/man ]; then
+ ( cd $PKG/usr/man
+ for manpagedir in $(find . -type d -name "man*") ; do
+ ( cd $manpagedir
+ for eachpage in $( find . -type l -maxdepth 1) ; do
+ ln -s $( readlink $eachpage ).gz $eachpage.gz
+ rm $eachpage
+ done
+ gzip -9 *.*
+ )
+ done
+ )
+fi
+
+# Even out-of-date manpages are better than nothing. IMHO.
+( cd $PKG/usr
+ tar xjf $CWD/netpbm-manpages.tar.bz2
+)
+
+# Add a documentation directory:
+( cd doc
+ cp -a \
+ COPYRIGHT.PATENT GPL_LICENSE.txt HISTORY INSTALL Netpbm.programming \
+ README* USERDOC copyright_summary lgpl_v21.txt \
+ $PKG/usr/doc/${PKGNAM}-$VERSION
+)
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $TMP/${PKGNAM}-$VERSION-$ARCH-$BUILD.txz
+