summaryrefslogtreecommitdiffstats
path: root/source/l/mozilla-nss/mozilla-nss.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/mozilla-nss/mozilla-nss.SlackBuild')
-rwxr-xr-xsource/l/mozilla-nss/mozilla-nss.SlackBuild30
1 files changed, 21 insertions, 9 deletions
diff --git a/source/l/mozilla-nss/mozilla-nss.SlackBuild b/source/l/mozilla-nss/mozilla-nss.SlackBuild
index 35e513d15..0d0f788e5 100755
--- a/source/l/mozilla-nss/mozilla-nss.SlackBuild
+++ b/source/l/mozilla-nss/mozilla-nss.SlackBuild
@@ -1,6 +1,6 @@
-#!/bin/sh
+#!/bin/bash
# Copyright 2005, 2006, 2008, 2009, 2010, 2012 Eric Hameleers, Eindhoven, NL
-# Copyright 2013, 2014, 2015 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2013, 2014, 2015, 2017, 2018 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Permission to use, copy, modify, and distribute this software for
@@ -22,10 +22,12 @@
# SUCH DAMAGE.
# -----------------------------------------------------------------------------
+cd $(dirname $0) ; CWD=$(pwd)
+
PKGNAM=mozilla-nss
SRCNAM=nss
-VERSION=${VERSION:-3.23}
-NSPR=${NSPR:-4.12}
+VERSION=${VERSION:-3.37.1}
+NSPR=${NSPR:-4.19}
BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
@@ -40,6 +42,14 @@ if [ -z "$ARCH" ]; then
esac
fi
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
+ exit 0
+fi
+
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
@@ -55,7 +65,6 @@ else
LIBDIRSUFFIX=""
fi
-CWD=$(pwd)
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
@@ -68,11 +77,14 @@ mkdir -p $TMP $PKG
cd $TMP
rm -rf nss-${VERSION}
rm -rf nspr-${NSPR}
-tar xvf $CWD/nss-$VERSION.tar.?z* || exit 1
+tar xvf $CWD/nss-$VERSION.tar.?z || exit 1
cd nss-$VERSION
-tar xvf $CWD/nspr-$NSPR.tar.?z* || exit 1
+tar xvf $CWD/nspr-$NSPR.tar.?z || exit 1
mv nspr*/nspr .
+# -Werror is problematic with gcc7:
+sed -i "s|\ -Werror| |" nss/coreconf/Werror.mk || exit 1
+
# Make sure ownerships and permissions are sane:
chown -R root:root .
find . \
@@ -91,8 +103,8 @@ export NSS_USE_SYSTEM_SQLITE=1
export NSS_ENABLE_ECC=1
cd nss
# Seems parallel build does not work with this.
- #make $NUMJOBS nss_build_all export
- make nss_build_all export
+ #make $NUMJOBS nss_build_all export || exit 1
+ make nss_build_all export || exit 1
cd -
# Install all the needed stuff to the package dir: