summaryrefslogtreecommitdiffstats
path: root/source/l/libzip/libzip.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/libzip/libzip.SlackBuild')
-rwxr-xr-xsource/l/libzip/libzip.SlackBuild38
1 files changed, 13 insertions, 25 deletions
diff --git a/source/l/libzip/libzip.SlackBuild b/source/l/libzip/libzip.SlackBuild
index d7103a30d..a841127ee 100755
--- a/source/l/libzip/libzip.SlackBuild
+++ b/source/l/libzip/libzip.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2007 Heinz Wiesinger <hmwiesinger@gmx.at>
+# Copyright 2007, 2013 Heinz Wiesinger, Amsterdam, The Netherlands
# Copyright 2008, 2009, 2010 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
@@ -76,39 +76,27 @@ CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
+ --includedir=/usr/include \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
--disable-static \
--build=$ARCH-slackware-linux
+# Fix symbolic linking for manpages
+sed -i "s|\${LN}|\${LN_S}|g" man/Makefile
+sed -i "s|\${LN_S} \${DESTDIR}\${man3dir}/|\${LN_S} |" man/Makefile
+
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
-# This installs hardlinked manpages, bleh!
-( cd $PKG/usr/man/man3
- # Break links by duplicating the files.
- for file in *.3 ; do
- cp -a $file tmp
- rm $file
- mv tmp $file
- done
-)
-# Make symlinks instead:
-( cd $PKG/usr/man/man3
- rm -rf zip_strerror.3
- ln -sf zip_file_strerror.3 zip_strerror.3
- rm -rf zip_replace.3
- ln -sf zip_add.3 zip_replace.3
- rm -rf zip_stat_index.3
- ln -sf zip_stat.3 zip_stat_index.3
- rm -rf zip_fopen_index.3
- ln -sf zip_fopen.3 zip_fopen_index.3
- rm -rf zip_file_error_get.3
- ln -sf zip_error_get.3 zip_file_error_get.3
- rm -rf zip_file_error_clear.3
- ln -sf zip_error_clear.3 zip_file_error_clear.3
-)
+# While I perhaps see the motive for putting platform-specific include files
+# in a place where they won't collide, the fact is that this breaks anything
+# currently using libzip. Adding a link to the standard include directory
+# mostly fixes this, but it is still not optimal. It's likely to cause
+# problems on multilib systems, for example (but like that whole thing isn't
+# an even uglier hack).
+( cd $PKG/usr/include ; ln -sf ../lib${LIBDIRSUFFIX}/libzip/include/zipconf.h . )
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null