summaryrefslogtreecommitdiffstats
path: root/source/l/libungif/libungif.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/libungif/libungif.SlackBuild')
-rwxr-xr-xsource/l/libungif/libungif.SlackBuild93
1 files changed, 0 insertions, 93 deletions
diff --git a/source/l/libungif/libungif.SlackBuild b/source/l/libungif/libungif.SlackBuild
deleted file mode 100755
index 5e9ff8c06..000000000
--- a/source/l/libungif/libungif.SlackBuild
+++ /dev/null
@@ -1,93 +0,0 @@
-#!/bin/sh
-
-# Copyright 2008, 2009 Patrick J. Volkerding, Sebeka, Minnesota, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-
-VERSION=4.1.4
-ARCH=${ARCH:-x86_64}
-NUMJOBS=${NUMJOBS:-" -j7 "}
-BUILD=${BUILD:-4}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "s390" ]; then
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp}
-PKG=$TMP/package-libungif
-rm -rf $PKG
-mkdir -p $TMP $PKG
-
-cd $TMP
-rm -rf libungif-$VERSION
-tar xvf $CWD/libungif-$VERSION.tar.bz2 || exit 1
-cd libungif-$VERSION
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --with-x=no \
- $ARCH-slackware-linux
-
-make $NUMJOBS || make || exit 1
-make install DESTDIR=$PKG || exit 1
-
-mkdir -p $PKG/usr/doc/libungif-$VERSION
-cp -a \
- AUTHORS BUGS COPYING ChangeLog INSTALL NEWS ONEWS README TODO \
- UNCOMPRESSED_GIF doc \
- $PKG/usr/doc/libungif-$VERSION
-rm $PKG/usr/doc/libungif-$VERSION/doc/Makefile*
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
-
-## I don't believe we need all this slop. Correct me if I'm wrong.
-# I've been corrected...
-#rm -rf $PKG/usr/bin
-
-( cd $PKG/usr/lib${LIBDIRSUFFIX}
- SOVER=$(/bin/ls libungif.so.*.*.* | cut -f 3-5 -d .)
- ln -sf libungif.so.$SOVER libgif.so.$SOVER
- ln -sf libgif.so.$SOVER libgif.so.4
- ln -sf libgif.so.4 libgif.so
- ln -sf libungif.a libgif.a )
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $TMP/libungif-$VERSION-$ARCH-$BUILD.txz
-