summaryrefslogtreecommitdiffstats
path: root/source/l/libplist/libplist.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/libplist/libplist.SlackBuild')
-rwxr-xr-xsource/l/libplist/libplist.SlackBuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/source/l/libplist/libplist.SlackBuild b/source/l/libplist/libplist.SlackBuild
index f64263e97..7f4be02aa 100755
--- a/source/l/libplist/libplist.SlackBuild
+++ b/source/l/libplist/libplist.SlackBuild
@@ -109,12 +109,21 @@ CXXFLAGS="$SLKCFLAGS" \
--disable-static \
--build=$ARCH-slackware-linux || exit 1
+# Hack this to link with -lm:
+sed -i "s/LIBS = -lpthread/LIBS = -lpthread -lm/g" src/Makefile
+
make $NUMJOBS || make || exit 1
make install DESTDIR=$PKG || exit 1
# Don't ship .la files:
rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+# Provide symlinks from the old pkgconfig names:
+( cd $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
+ ln -sf libplist++-2.*.pc libplist++.pc
+ ln -sf libplist-2.*.pc libplist.pc
+)
+
# Strip binaries:
find $PKG | xargs file | grep -e "executable" -e "shared object" \
| grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null