summaryrefslogtreecommitdiffstats
path: root/source/l/jasper/jasper.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/jasper/jasper.SlackBuild')
-rwxr-xr-xsource/l/jasper/jasper.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/source/l/jasper/jasper.SlackBuild b/source/l/jasper/jasper.SlackBuild
index ec0ecddfe..6d9878a12 100755
--- a/source/l/jasper/jasper.SlackBuild
+++ b/source/l/jasper/jasper.SlackBuild
@@ -74,9 +74,9 @@ cd $PKGNAM-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
# Building docs needs texlive, and no easy way to disable it via cmake
sed -i "/add_subdirectory(doc)/d" CMakeLists.txt
@@ -101,9 +101,9 @@ mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a \
COPYRIGHT INSTALL LICENSE README* \
$PKG/usr/doc/$PKGNAM-$VERSION
-find $PKG/usr/doc -type f -exec chmod 644 {} \;
+find $PKG/usr/doc -type f -exec chmod 644 {} \+
-find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
+find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \+
for i in $(find $PKG/usr/man -type l -name "*.?") ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
find $PKG | xargs file | grep -e "executable" -e "shared object" \