summaryrefslogtreecommitdiffstats
path: root/source/l/gtk+3/gtk+3.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/gtk+3/gtk+3.SlackBuild')
-rwxr-xr-xsource/l/gtk+3/gtk+3.SlackBuild43
1 files changed, 9 insertions, 34 deletions
diff --git a/source/l/gtk+3/gtk+3.SlackBuild b/source/l/gtk+3/gtk+3.SlackBuild
index c4e972eb5..55a69bcac 100755
--- a/source/l/gtk+3/gtk+3.SlackBuild
+++ b/source/l/gtk+3/gtk+3.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2008, 2009, 2010, 2011 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008, 2009, 2010, 2011, 2013 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,7 +22,7 @@
VERSION=${VERSION:-$(echo gtk+-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
NUMJOBS=${NUMJOBS:-" -j7 "}
@@ -68,9 +68,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Use /etc/gtk-3.0/$ARCH-slackware-linux instead of /etc/gtk-3.0/ for gtk.immodules
-zcat $CWD/use_host_triplet_for_gtk_immodules.diff.gz | patch -p1 --verbose || exit 1
-
# Regenerate ./configure:
libtoolize --copy --force
autoreconf -vif
@@ -79,54 +76,32 @@ autoreconf -vif
# Our host is $ARCH-slackware-linux not $ARCH-slackware-linux-gnu:
sed -i -e 's#linux|linux-gnu|#linux|linux|#' config.sub
-CFLAGS="$SLKCFLAGS -DHOST='"'"${ARCH}-slackware-linux"'"'" \
+CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
--mandir=/usr/man \
--enable-xkb \
- --build=$ARCH-slackware-linux \
- --host=$ARCH-slackware-linux \
- --target=$ARCH-slackware-linux
+ --enable-packagekit=no \
+ --build=$ARCH-slackware-linux
# --enable-gtk-doc-html=no \
-# See modules/input/Makefile.am
-make \
- imconffiledir=/etc/gtk-3.0/$ARCH-slackware-linux \
- $NUMJOBS || make || exit 1
+make $NUMJOBS || make || exit 1
# Check the host value that is passed to the compile to the one in this script:
host="$ARCH-slackware-linux"
-# Best I can tell, it doesn't matter if they match. Since gtk+3-3.2.0, both
-# build_triplet and host_triplet have "-gnu" appended to them, but neither of
-# those seem to actually be used anywhere. Commenting out unless I find out
-# that I'm wrong later... :-) --rworkman
-#compile_host=$(grep 'host_triplet =' gtk/Makefile | sed -e "s/.* = //")
-#if [ "x$compile_host" != "x$host" ]; then
-# echo "Host mismatch: compile='$compile_host', SlackBuild='$host'" && exit 1
-#fi
make install \
- imconffiledir=/etc/gtk-3.0/$ARCH-slackware-linux \
RUN_QUERY_IMMODULES_TEST=false RUN_QUERY_LOADER_TEST=false \
DESTDIR=$PKG \
|| exit 1
-# You'll probably need to install the newly made package right away to
-# fix the result of this next line, but we had to clear this. Sorry.
-rm -rf /etc/gtk-3.0
-# I'm spamming your root partition because /etc/gtk-3.0 won't install to $DESTDIR...
-make install imconffiledir=/etc/gtk-3.0/$ARCH-slackware-linux
-cp -a /etc/gtk-3.0 $PKG/etc || exit 1
-mv $PKG/etc/gtk-3.0/$host/im-multipress.conf $PKG/etc/gtk-3.0/im-multipress.conf.new
-rm -f $PKG/etc/gtk-3.0/$host/*
-if [ -r $PKG/etc/gtk-3.0/gtk.immodules ]; then
- mv $PKG/etc/gtk-3.0/gtk.immodules $PKG/etc/gtk-3.0/$host/
-fi
+# Don't clobber im-multipress.conf
+mv $PKG/etc/gtk-3.0/im-multipress.conf $PKG/etc/gtk-3.0/im-multipress.conf.new
# Install a "starter" gtkrc
-echo 'gtk-theme-name="GTK+"' > $PKG/etc/gtk-3.0/gtkrc.new
+echo 'gtk-theme-name="Adwaita"' > $PKG/etc/gtk-3.0/gtkrc.new
# We need to have separate 32-bit and 64-bit binaries
# for places where we have two copies of the GTK+ package installed.