summaryrefslogtreecommitdiffstats
path: root/source/l/gc/gc.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/gc/gc.SlackBuild')
-rwxr-xr-xsource/l/gc/gc.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/source/l/gc/gc.SlackBuild b/source/l/gc/gc.SlackBuild
index 112e44475..b2a0a9f22 100755
--- a/source/l/gc/gc.SlackBuild
+++ b/source/l/gc/gc.SlackBuild
@@ -25,9 +25,9 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=gc
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-3}
+BUILD=${BUILD:-1}
-LAO_VERSION="7.6.10" # libatomic_ops version
+LAO_VERSION="7.8.2" # libatomic_ops version
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -74,6 +74,7 @@ tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-$VERSION 2> /dev/null || cd $PKGNAM-$(echo $VERSION | cut -b 1-3) || exit 1
tar xvf $CWD/libatomic_ops-$LAO_VERSION.tar.?z || exit 1
mv libatomic_ops-$LAO_VERSION libatomic_ops
+
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -83,7 +84,7 @@ find . \
sed -i 's#pkgdata#doc#' doc/doc.am
sed -i 's#pkgdata#doc#' libatomic_ops/Makefile.am
-sed -i 's#pkgdata#doc#' libatomic_ops/doc/Makefile.am
+#sed -i 's#pkgdata#doc#' libatomic_ops/doc/Makefile.am
autoreconf -vif
automake --add-missing