summaryrefslogtreecommitdiffstats
path: root/source/l/gc/gc.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/gc/gc.SlackBuild')
-rwxr-xr-xsource/l/gc/gc.SlackBuild48
1 files changed, 24 insertions, 24 deletions
diff --git a/source/l/gc/gc.SlackBuild b/source/l/gc/gc.SlackBuild
index 186f39872..d3dba1ccd 100755
--- a/source/l/gc/gc.SlackBuild
+++ b/source/l/gc/gc.SlackBuild
@@ -1,6 +1,6 @@
-#!/bin/sh
+#!/bin/bash
-# Copyright 2013, 2014, 2015 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2013, 2014, 2015, 2018 Patrick J. Volkerding, Sebeka, MN, USA
# Copyright 2014 Heinz Wiesinger, Amsterdam, NL
# All rights reserved.
#
@@ -21,10 +21,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=gc
-VERSION=${VERSION:-$(echo $PKGNAM-*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+BUILD=${BUILD:-2}
+
+LAO_VERSION="7.6.2" # libatomic_ops version
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -36,9 +39,16 @@ if [ -z "$ARCH" ]; then
esac
fi
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
+ exit 0
+fi
+
NUMJOBS=${NUMJOBS:-" -j7 "}
-CWD=$(pwd)
TMP=${TMP:-/tmp}
PKG=$TMP/package-$PKGNAM
rm -rf $PKG
@@ -60,10 +70,10 @@ fi
cd $TMP
rm -rf $PKGNAM-$VERSION $PKGNAM-$(echo $VERSION | cut -b 1-3)
-tar xvf $CWD/$PKGNAM-$VERSION.tar.xz || exit 1
+tar xvf $CWD/$PKGNAM-$VERSION.tar.?z || exit 1
cd $PKGNAM-$VERSION 2> /dev/null || cd $PKGNAM-$(echo $VERSION | cut -b 1-3) || exit 1
-tar xvf $CWD/libatomic_ops-$VERSION.tar.xz || exit 1
-mv libatomic_ops-$VERSION libatomic_ops
+tar xvf $CWD/libatomic_ops-$LAO_VERSION.tar.?z || exit 1
+mv libatomic_ops-$LAO_VERSION libatomic_ops
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -71,13 +81,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# https://github.com/ivmai/bdwgc/pull/51
-zcat $CWD/noelision.patch.gz | patch -p1 --verbose || exit 1
-
-# Guarding GC_setup_mark_lock usage with PARALLEL_MARK is required to avoid
-# an undefined reference in non-PARALLEL_MARK configurations:
-zcat $CWD/refer_to_GC_setup_mark_lock_only_in_PARALLEL_MARK_code.patch.gz | patch -p0 --verbose || exit 1
-
sed -i 's#pkgdata#doc#' doc/doc.am
sed -i 's#pkgdata#doc#' libatomic_ops/Makefile.am
sed -i 's#pkgdata#doc#' libatomic_ops/doc/Makefile.am
@@ -99,7 +102,7 @@ CFLAGS="$SLKCFLAGS -DUSE_GET_STACKBASE_FOR_MAIN" \
--enable-parallel-mark \
--enable-threads=posix \
--with-libatomic-ops=no \
- --build=$ARCH-slackware-linux
+ --build=$ARCH-slackware-linux || exit 1
# NOTE: Using --disable-static exports a subset of symbols, and has caused
# some things that use gc to break. So it is recommended to build the static
@@ -118,14 +121,11 @@ cd libatomic_ops
make install DESTDIR=$PKG || exit 1
cd -
-# Remove static libraries that we don't want in the package, and fix the
-# .la files to remove the references to them:
-( cd $PKG/usr/lib${LIBDIRSUFFIX}
- for static in libcord libgc libgccpp ; do
- rm --verbose ${static}.a
- sed -i "s#old_library='.*'#old_library=''#g" ${static}.la
- done
-)
+# Remove static libraries that we don't want in the package:
+rm -f $PKG/usr/lib${LIBDIRSUFFIX}/{libcord,libgc,libgccpp}.a
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null