summaryrefslogtreecommitdiffstats
path: root/source/l/dconf/dconf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/dconf/dconf.SlackBuild')
-rwxr-xr-xsource/l/dconf/dconf.SlackBuild9
1 files changed, 1 insertions, 8 deletions
diff --git a/source/l/dconf/dconf.SlackBuild b/source/l/dconf/dconf.SlackBuild
index cc4e6d297..c0ad9a1c1 100755
--- a/source/l/dconf/dconf.SlackBuild
+++ b/source/l/dconf/dconf.SlackBuild
@@ -25,7 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=dconf
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -78,13 +78,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-# We're going to assume that this is needed until further notice:
-# Fix duplicate symbols at link time with meson-0.52.{0,1}, 0.53.{0,1}:
-#if [ "$(meson --version)" = "0.52.0" -o "$(meson --version)" = "0.52.1" -o "$(meson --version)" = "0.53.0" -o "$(meson --version)" = "0.53.1" ]; then
- sed -i 's|link_whole|link_with|' client/meson.build &&
- sed -i 's/module/& | grep -v mangle_path/' gsettings/abicheck.sh
-#fi
-
# Configure, build, and install:
export CFLAGS="$SLKCFLAGS"
export CXXFLAGS="$SLKCFLAGS"