summaryrefslogtreecommitdiffstats
path: root/source/l/dconf/dconf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/dconf/dconf.SlackBuild')
-rwxr-xr-xsource/l/dconf/dconf.SlackBuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/source/l/dconf/dconf.SlackBuild b/source/l/dconf/dconf.SlackBuild
index 927bba200..1aa481fca 100755
--- a/source/l/dconf/dconf.SlackBuild
+++ b/source/l/dconf/dconf.SlackBuild
@@ -25,7 +25,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=dconf
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -80,7 +80,8 @@ find . \
# Fix duplicate symbols at link time with meson-0.52.{0,1}:
if [ "$(meson --version)" = "0.52.0" -o "$(meson --version)" = "0.52.1" ]; then
- sed -i "s/link_whole: libdconf_common,/link_with: libdconf_common,/g" common/meson.build
+ sed -i 's|link_whole|link_with|' client/meson.build &&
+ sed -i 's/module/& | grep -v mangle_path/' gsettings/abicheck.sh
fi
# Configure, build, and install: