summaryrefslogtreecommitdiffstats
path: root/source/l/brotli/brotli.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/brotli/brotli.SlackBuild')
-rwxr-xr-xsource/l/brotli/brotli.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/source/l/brotli/brotli.SlackBuild b/source/l/brotli/brotli.SlackBuild
index c6748fa96..39aec12eb 100755
--- a/source/l/brotli/brotli.SlackBuild
+++ b/source/l/brotli/brotli.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 2019 Eric Hameleers, Eindhoven, NL
-# Copyright 2020 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2020, 2023 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,13 +25,13 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=brotli
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-5}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$(uname -m)" in
i?86) ARCH=i586 ;;
- arm*) readelf /usr/bin/file -A | egrep -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
+ arm*) readelf /usr/bin/file -A | grep -E -q "Tag_CPU.*[4,5]" && ARCH=arm || ARCH=armv7hl ;;
# Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$(uname -m) ;;
esac
@@ -86,9 +86,6 @@ find . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \+
-# Remove -R that is not accepted by the C compiler:
-zcat $CWD/brotli.no.unrecognized.R.diff.gz | patch -p1 --verbose || exit 1
-
# Configure, build, and install:
mkdir cmake-build
cd cmake-build
@@ -110,7 +107,7 @@ cd cmake-build
cd ..
# Only add python3 support. We're not adding any Python 2 junk now...
-python3 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG || exit 1
# No static libraries:
rm -f $PKG/usr/lib${LIBDIRSUFFIX}/*.a