summaryrefslogtreecommitdiffstats
path: root/source/l/M2Crypto/M2Crypto.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/l/M2Crypto/M2Crypto.SlackBuild')
-rwxr-xr-xsource/l/M2Crypto/M2Crypto.SlackBuild51
1 files changed, 35 insertions, 16 deletions
diff --git a/source/l/M2Crypto/M2Crypto.SlackBuild b/source/l/M2Crypto/M2Crypto.SlackBuild
index 359ba2b2b..ab134c786 100755
--- a/source/l/M2Crypto/M2Crypto.SlackBuild
+++ b/source/l/M2Crypto/M2Crypto.SlackBuild
@@ -1,7 +1,7 @@
-#!/bin/sh
+#!/bin/bash
# Copyright 2009 Robby Workman, Northport, Alabama, USA
-# Copyright 2009, 2010 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2009, 2010, 2018 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,10 +21,11 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=M2Crypto
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-4}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -36,20 +37,17 @@ if [ -z "$ARCH" ]; then
esac
fi
-CWD=$(pwd)
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PKGNAM-$VERSION-$ARCH-$BUILD.txz"
+ exit 0
+fi
+
TMP=${TMP:-/tmp}
PKG=${PKG:-$TMP/package-M2Crypto}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
-else
- SLKCFLAGS="-O2"
-fi
-
rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
@@ -65,6 +63,28 @@ find . \
python setup.py install --root=$PKG || exit 1
+mkdir -p $PKG/usr/doc/M2Crypto-$VERSION
+cp -a \
+ CHANGES INSTALL* LICENCE* PKG-INFO README* doc/* \
+ $PKG/usr/doc/M2Crypto-$VERSION
+
+# Embed required dep typing module:
+cd $TMP
+rm -rf typing-3.6.4
+tar xvf $CWD/typing-3.6.4.tar.xz || exit 1
+cd typing-3.6.4 || exit 1
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+python setup.py install --root=$PKG || exit 1
+mkdir -p $PKG/usr/doc/typing-3.6.4
+cp -a \
+ CHANGES INSTALL* LICENCE* PKG-INFO README* doc/* \
+ $PKG/usr/doc/typing-3.6.4
+
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
@@ -74,7 +94,7 @@ python setup.py install --root=$PKG || exit 1
mkdir -p $PKG/usr/doc/M2Crypto-$VERSION
cp -a \
- CHANGES INSTALL LICENCE PKG-INFO README* doc/* \
+ CHANGES INSTALL* LICENCE* PKG-INFO README* doc/* \
$PKG/usr/doc/M2Crypto-$VERSION
mkdir -p $PKG/install
@@ -82,4 +102,3 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/M2Crypto-$VERSION-$ARCH-$BUILD.txz
-