summaryrefslogtreecommitdiffstats
path: root/source/d/scons/scons.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/scons/scons.SlackBuild')
-rwxr-xr-xsource/d/scons/scons.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/source/d/scons/scons.SlackBuild b/source/d/scons/scons.SlackBuild
index 88bd1ebb3..41daaca52 100755
--- a/source/d/scons/scons.SlackBuild
+++ b/source/d/scons/scons.SlackBuild
@@ -72,9 +72,9 @@ cd scons-$VERSION || exit 1
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
python setup.py install \
--no-version-script \
@@ -85,7 +85,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
+ find . -type f -exec gzip -9 {} \+
for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
)