summaryrefslogtreecommitdiffstats
path: root/source/d/python/python.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/python/python.SlackBuild')
-rwxr-xr-xsource/d/python/python.SlackBuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/source/d/python/python.SlackBuild b/source/d/python/python.SlackBuild
index d1d37a6db..4a51a71ee 100755
--- a/source/d/python/python.SlackBuild
+++ b/source/d/python/python.SlackBuild
@@ -90,9 +90,9 @@ fi
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ -exec chmod 644 {} \+
# Enable built-in SQLite module to load extensions
sed -i "/SQLITE_OMIT_LOAD_EXTENSION/d" setup.py
@@ -146,9 +146,9 @@ chown -R root:root $PKG/usr/doc/python-$VERSION
# Fix possible incorrect permissions:
( cd $PKG
- find . -type d -exec chmod 755 "{}" \;
- find . -perm 640 -exec chmod 644 "{}" \;
- find . -perm 750 -exec chmod 755 "{}" \;
+ find . -type d -exec chmod 755 "{}" \+
+ find . -perm 640 -exec chmod 644 "{}" \+
+ find . -perm 750 -exec chmod 755 "{}" \+
)
@@ -165,7 +165,7 @@ chown -R root:root $PKG/usr/doc/python-$VERSION
)
( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
+ find . -type f -exec gzip -9 {} \+
for i in $(find . -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
)