summaryrefslogtreecommitdiffstats
path: root/source/d/python-pip/python-pip.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/python-pip/python-pip.SlackBuild')
-rwxr-xr-xsource/d/python-pip/python-pip.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/source/d/python-pip/python-pip.SlackBuild b/source/d/python-pip/python-pip.SlackBuild
index 8fb4432e7..c4171e8b2 100755
--- a/source/d/python-pip/python-pip.SlackBuild
+++ b/source/d/python-pip/python-pip.SlackBuild
@@ -57,9 +57,9 @@ cd $SRCNAM-$VERSION || exit 1
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG || exit 1
@@ -72,7 +72,7 @@ python setup.py install --root=$PKG || exit 1
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a *.txt PKG-INFO README.rst \
$PKG/usr/doc/$PKGNAM-$VERSION
-find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 0644 {} \;
+find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 0644 {} \+
# If there's a CHANGES.txt, installing at least part of the recent history
# is useful, but don't let it get totally out of control: