summaryrefslogtreecommitdiffstats
path: root/source/d/meson/meson.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/meson/meson.SlackBuild')
-rwxr-xr-xsource/d/meson/meson.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/source/d/meson/meson.SlackBuild b/source/d/meson/meson.SlackBuild
index 860dd31f1..42c5da47c 100755
--- a/source/d/meson/meson.SlackBuild
+++ b/source/d/meson/meson.SlackBuild
@@ -56,9 +56,9 @@ cd $PKGNAM-$VERSION || exit 1
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
# Fix meson configure crash:
zcat $CWD/meson.47bdea504067d00e9bed522e9575bd2416bfe4ee.patch.gz | patch -p1 --verbose || exit 1
@@ -68,13 +68,13 @@ python3 setup.py install --root=$PKG || exit 1
mv $PKG/usr/share/man $PKG/usr/
rmdir $PKG/usr/share 2> /dev/null
-find $PKG/usr/man -type f -exec gzip -9 {} \;
+find $PKG/usr/man -type f -exec gzip -9 {} \+
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PKGNAM-$VERSION
cp -a contributing.txt COPYING PKG-INFO README* \
$PKG/usr/doc/$PKGNAM-$VERSION
-find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 0644 {} \;
+find $PKG/usr/doc/$PKGNAM-$VERSION -type f -exec chmod 0644 {} \+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc