summaryrefslogtreecommitdiffstats
path: root/source/d/help2man/help2man.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xsource/d/help2man/help2man.SlackBuild (renamed from testing/source/xf86-video-intel/xf86-video-intel.SlackBuild)28
1 files changed, 21 insertions, 7 deletions
diff --git a/testing/source/xf86-video-intel/xf86-video-intel.SlackBuild b/source/d/help2man/help2man.SlackBuild
index 5498e7fbf..bc93fffae 100755
--- a/testing/source/xf86-video-intel/xf86-video-intel.SlackBuild
+++ b/source/d/help2man/help2man.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/sh
-# Copyright 2012 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2013 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,7 +21,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-PKGNAM=xf86-video-intel
+PKGNAM=help2man
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
BUILD=${BUILD:-1}
@@ -84,16 +84,14 @@ find . \
-exec chmod 644 {} \;
# Configure:
-CFLAGS=$SLKCFLAGS \
+CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
--sysconfdir=/etc \
- --localstatedir=/var \
--infodir=/usr/info \
--mandir=/usr/man \
- --docdir=/usr/doc/xf86-video-fbdev-$VERSION \
- --disable-static \
+ --localstatedir=/var \
--build=$ARCH-slackware-linux
# Build and install:
@@ -109,7 +107,7 @@ make install DESTDIR=$PKG || exit 1
# Add a documentation directory:
mkdir -p $PKG/usr/doc/${PKGNAM}-$VERSION
cp -a \
- COPYING* README* NEWS* \
+ COPYING* INSTALL NEWS README* THANKS \
$PKG/usr/doc/${PKGNAM}-$VERSION
# Compress and if needed symlink the man pages:
@@ -127,6 +125,22 @@ if [ -d $PKG/usr/man ]; then
)
fi
+# Compress info files, if any:
+if [ -d $PKG/usr/info ]; then
+ ( cd $PKG/usr/info
+ rm -f dir
+ gzip -9 *
+ )
+fi
+
+# If there's a ChangeLog, installing at least part of the recent history
+# is useful, but don't let it get totally out of control:
+if [ -r debian/changelog ]; then
+ DOCSDIR=$(echo $PKG/usr/doc/${PKGNAM}-$VERSION)
+ cat debian/changelog | head -n 1000 > $DOCSDIR/ChangeLog
+ touch -r debian/changelog $DOCSDIR/ChangeLog
+fi
+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc