summaryrefslogtreecommitdiffstats
path: root/source/d/Cython/Cython.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/d/Cython/Cython.SlackBuild')
-rwxr-xr-xsource/d/Cython/Cython.SlackBuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/source/d/Cython/Cython.SlackBuild b/source/d/Cython/Cython.SlackBuild
index 54eae3ced..843f3ef18 100755
--- a/source/d/Cython/Cython.SlackBuild
+++ b/source/d/Cython/Cython.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=Cython
VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -63,6 +63,11 @@ find -L . \
python3 setup.py install --root=$PKG --prefix=/usr || exit 1
+# Make cython3 symlink:
+if [ ! -x $PKG/usr/bin/cython3 ]; then
+ ( cd $PKG/usr/bin ; ln -sf cython cython3)
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true