summaryrefslogtreecommitdiffstats
path: root/source/ap/screen/screen.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/ap/screen/screen.SlackBuild')
-rwxr-xr-xsource/ap/screen/screen.SlackBuild14
1 files changed, 4 insertions, 10 deletions
diff --git a/source/ap/screen/screen.SlackBuild b/source/ap/screen/screen.SlackBuild
index 277ae041d..dc7f2ded7 100755
--- a/source/ap/screen/screen.SlackBuild
+++ b/source/ap/screen/screen.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2008, 2009, 2010, 2011, 2013, 2014, 2015, 2016, 2018 Patrick J. Volkerding, Sebeka, Minnesota, USA
+# Copyright 2008, 2009, 2010, 2011, 2013, 2014, 2015, 2016, 2018, 2019 Patrick J. Volkerding, Sebeka, Minnesota, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,8 +23,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=screen
-VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+BUILD=${BUILD:-1}
# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
@@ -63,7 +63,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG
cd $TMP
rm -rf screen-$VERSION
-tar xvf $CWD/screen-$VERSION.tar.?z* || exit 1
+tar xvf $CWD/screen-$VERSION.tar.?z || exit 1
cd screen-$VERSION || exit 1
@@ -86,12 +86,6 @@ done
# the console from being properly cleared when detaching from a screen session:
zcat $CWD/60-revert-screenrc-change.diff.gz | patch -p1 --verbose || exit 1
-# Do not link against libelf:
-zcat $CWD/screen.no_libelf.diff.gz | patch -p1 --verbose || exit 1
-
-# Reconf after patching configure.ac:
-autoreconf -vif
-
# Configure:
CFLAGS="$SLKCFLAGS" \
./configure \