summaryrefslogtreecommitdiffstats
path: root/source/ap/man-pages/man-pages.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'source/ap/man-pages/man-pages.SlackBuild')
-rwxr-xr-xsource/ap/man-pages/man-pages.SlackBuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/source/ap/man-pages/man-pages.SlackBuild b/source/ap/man-pages/man-pages.SlackBuild
index 8d0035849..c44d37fac 100755
--- a/source/ap/man-pages/man-pages.SlackBuild
+++ b/source/ap/man-pages/man-pages.SlackBuild
@@ -1,6 +1,6 @@
#!/bin/bash
-# Copyright 2008-2018 Patrick J. Volkerding, Sebeka, MN, USA
+# Copyright 2008-2019 Patrick J. Volkerding, Sebeka, MN, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PKGNAM=man-pages
-VERSION=${VERSION:-$(echo man-pages-4.*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
+VERSION=${VERSION:-$(echo man-pages-5.*.tar.xz | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
ARCH=noarch
BUILD=${BUILD:-1}
@@ -43,8 +43,9 @@ mkdir -p $TMP $PKG
cd $TMP
rm -rf man-pages-$VERSION
-tar xf $CWD/man-pages-$VERSION.tar.xz
-tar xf $CWD/man-pages-posix-2013-a.tar.xz
+tar xvf $CWD/man-pages-$VERSION.tar.xz
+tar xvf $CWD/man-pages-posix-2013-a.tar.xz
+echo "Fixing permissions..."
chown -R root:root man-pages-$VERSION man-pages-posix-2013-a
chmod -R a-s,u+rw,go+r-w man-pages-$VERSION man-pages-posix-2013-a
find man-pages-$VERSION \
@@ -78,10 +79,12 @@ rm -f $PKG/usr/man/Makefile
rm -f $PKG/usr/man/Changes.old
# Compress the pages:
+echo "Compressing manpages..."
gzip -9 $PKG/usr/man/man*/*.*
# If a man page exists in some other package, assume that's the
# newer, better version:
+echo "Pruning manpages found in other packages..."
( cd $PKG
for file in usr/man/man*/*.gz ; do
if grep -l $file /var/log/packages/* | grep -v var/log/packages/man-pages ; then
@@ -98,4 +101,3 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $TMP/man-pages-$VERSION-$ARCH-$BUILD.txz
-